VPN - Virtual Private Network

In una VPN, tutti i dati che si inviano e ricevono viaggiano attraverso un tunnel crittografato, così nessuno può mettere le mani sulle tue informazioni private.
Così, anche se un criminale informatico riuscisse in qualche modo a intercettare i tuoi dati, non sarebbe in grado di decifrarli.



Router 1
interface Tunnel1
 ip address 172.16.1.1 255.255.255.0
 mtu 1476
 tunnel source FastEthernet0/0
 tunnel destination 2.2.2.2
!
interface FastEthernet0/0
 ip address 192.168.1.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 1.1.1.2 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 router-id 192.168.1.1
 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.1.0 0.0.0.255 area 0
 network 1.1.1.0 0.0.0.3 area 0
!
ip route 0.0.0.0 0.0.0.0 1.1.1.1 

Router 2
interface Tunnel1
 ip address 172.16.1.2 255.255.255.0
 mtu 1476
 tunnel source FastEthernet0/0
 tunnel destination 1.1.1.1
!
interface FastEthernet0/0
 ip address 192.168.2.1 255.255.255.0
 duplex auto
 speed auto
!
interface FastEthernet0/1
 ip address 2.2.2.2 255.255.255.252
 duplex auto
 speed auto
!
router ospf 1
 router-id 192.168.2.1
 log-adjacency-changes
 network 172.16.0.0 0.0.255.255 area 0
 network 192.168.2.0 0.0.0.255 area 0
 network 2.2.2.0 0.0.0.3 area 0
!
ip route 0.0.0.0 0.0.0.0 2.2.2.1